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September 8, 2021 (Version 12.5.0) 
 

Enhancements 

Accounts Payable 

• Reports > 1099s: Updated 1099 and 1096 forms for the year 2021. 

Loan Processing 

• Reports > 1098s: Updated 1098's for the year 2021. 

Payroll 

• Modify > Tax Table Information: Updated withholding tax tables for the state of OHIO.  The 
effective date is September 1. 

Fixes 

Accounts Payable 

• Modify > Company Information: Corrected an issue that occurred when clicking the 
Link To Purchasing Management, and the Purchase Order was created in a prior year. 

• Manage > Payment Processing: Fixed an issue where overflow vouchers didn't appear 
after reprinting checks. 

• Manage > Recurring Payments: The program now honors the limit where a limit is 
included. 

• Manage > Recurring Payments: Fixed account rights so that if the user does not have 
account rights to any detail line in a recurring payment, then the entire recurring payment 
will be hidden. 

• Reports > 1099s: Fixed the 1099 Misc form for year 2019 so that it shows amounts on 
box 7. 

• View > Transaction Inquiry: Corrected an issue that was preventing a user from 
viewing some attachments made in Purchasing Management. 

• Manage > Unposted Transactions: Fixed issue with tax, freight, and other charges not 
carrying over when linking transactions to purchase orders. 

• Manage > Unposted Transactions: When applying a discount to an invoice, the 
program now calculates and applies the correct values. 

• Enter > Transactions: Fixed the entry so that it brings over the note entered in 
Purchase Management requests. 
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• Manage > Unposted Transactions: Fixed issue where notes, setup information, and 
projection information was not printing on the input audit report. 

• Manage > Unposted Transactions:   Corrected an issue that occurred when applying 
an existing Distribution, which contained information in the Note tab, the program was not 
applying the note to the Invoice Note field. 

• Utilities > Void Check: Corrected an issue where multiple checks would merge together, 
if multiple checks had the same Vendor, Check Number, and Check Date. 

Accounts Receivable 

• Manage > Unposted Invoices: Fixed the Invoice Edit report title. 

• Modify > Statement Design: Fixed an issue where users could not remove Images in 
the Statement report. 

• Manage > Payment Processing: Fixed an error when applying a credit invoice with a 
negative amount. 

• Manage > Payment Processing: Removed Outstanding total from reports due to 
misleading calculations. 

• Manage > Recurring Charges: Fixed transferring recurring charges to honor the option 
to save invoice detail as separate invoices. 

• Reports > Monthly Statements: Fixed the Charges total in the heading. 

• Manage > Unposted Invoices: Fixed ACH file issue where it was using date instead of 
"AUTOPAYMNT". 

Donors And Gifts 

• Reports > Analysis: Fixed an issue in the date range filter that could error when running 
the report using specific dates. 

Fixed Assets 

• Manage > Calculate Depreciation: Added code to correct user input when the date is 
not formatted correctly. 

General Ledger 

• Modify > Account Structure: Fixed to stop unchecking fund from account structure if 
the only fund is not Fund 0. 

• Reports > Budgeted Financial Statement: Updated the report export option to include 
opening and closing balances. 
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• Modify > Special Reports Setup: Fixed total lines not showing in some special reports 
when the account heading was not displayed. 

• Modify > Special Reports Setup: Fixed the Preliminary Budget Special Reports to show 
account groups. 

• Manage > Unposted Journals: Entries hitting Bank Account Management will no longer 
post to inactive accounts 

• Widgets > Budget Comparison: The General Ledger Home screen widget now shows 
activity correctly even where there are no Special Reports setup. 

• Modify > Year and Periods: Corrected an issue where a user is trying to switch from a 
calendar year to a fiscal year. 

Payroll 

• Utilities > Change Check Dates: When choosing the option to change check dates, 
users are no longer limited to select the current year postings. 

• Modify > Employee Information: Fixed an issue where a user was unable to delete 
Compensations or Deductions. 

• Manage > Payroll Processing: Corrected an issue on paychecks that have used the 
same distribution multiple times.  The check stub and register now show correct totals. 

• Utilities > Void Checks: Fixed an issue which prevented users from voiding a check if 
there were more than one transaction with the same check number. 

Purchasing Management 

• Manage > Requests: Corrected an issue in the Payment Approval process that allowed 
submitting an invoice without detail lines or amounts. 

• Modify > Approval Paths: Approval Paths setup for use only for Payment Approval, no 
longer appear when selecting or creating a request. 

• Modify > Company Information: Fixed an issue where "Force Account #'s on 
Requisitions?" check was not being honored when enabled. 

• Manage > Requests: Users are now allowed to choose a closed period when selecting 
the Period to encumber the associated funds. 

• Manage > Requests: Attachments placed on a request in Purchasing Management are 
viewable in AP and PM. 

• Manage > Requests: When a requester creates a purchase order and 1 or more 
approvers approve the request, the requester can no longer change the vendor. 
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• Manage > Requests: Manually closed detail lines on an existing purchase order now 
closes the purchase order when clicking the Update button. 

• Portal: Fixed the portal to use the computer's system clock to load the default period 
when entering a new purchase management request. 

Utilities 

• Utilities > Ad Hoc Reports: Fixed scrolling and height of the grid. 
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August 17, 2021 (Version 12.4.1) 
NOTE: (self-hosted) Release 12.4.1 also includes 12.4.0 changes.  

 

Fixes 

Accounts Receivable 

• Manage > Unposted Invoices: Fixed issue where posting invoices to revenue centers in 
Cash Basis was creating a journal entry. 

• Manage > Unposted Invoices: Fixed to not update the payment amounts twice when 
processing ACH. 

General Ledger 

• Reports > Statement of Activities: Fixed an error message that occurred when running 
the report. 

• Reports > Budgeted Financial Statement: Fixed error message that occurred when 
running the report. 

Payroll 

• Reports > 941 Summary: Fixed an error message that occurred when running the 
Report. 
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August 12, 2021 (Version 12.4.0) 
 

Enhancements 

Accounts Payable 

• Manage > Unposted Transactions: Added a Preferences option allowing you customize 
your entry preferences for faster entry.  Checkmark just the fields you want to show on 
the entry screen in the first column, “Show”. In the second column, “Skip”, just 
checkmark any fields that you want to tab over, but still use when needed. Save your 
settings. Test the results. Return to Preferences to modify anytime you want to make a 
change. 

 

Payroll 

• Reports > W 2s: Updated W2 and W3 forms for 2021. 

Remittance 

• Reports > Detail Remittance List: The detail reports now include sort by and display 
Project. 
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Fixes 

Accounts Payable 

• Manage > Payment Processing: Fixed an error when saving a payment (on accrual 
basis), where the invoice used an account that was not in the current year. 

• Manage > Payment Processing: Fixed an error in the payment processing filter that 
could result in too many parameters. 

Accounts Receivable 

• View > Transaction Inquiry: Fixed the order for invoice details to not change when 
reprinting invoices. 

Bank Account Management 

• Manage > Bank Statements: Creating a new Reconciliation Period no longer adds check 
marks to outstanding items. 

Donors And Gifts 

• Reports > Statements: Changed the query to pull people that have given within the 
date range selected. 

• Reports > Pledge List: Fixed the report so that it works when there are pledges without 
sub-donor. 

General Ledger 

• Manage > Recurring Journals: When transferring recurring journals, the program no 
longer shows the entries are out of balance. 

• Reports > Budgeted Financial Statement: Fixed an issue that occurred when changing 
an account number in the current year.  The program no longer breaks the link to 
previous year. 

Portal 

• Portal > Accounts Receivable: Fixed the portal to not allow users to click the “Process 
Payments” button when the amounts are either zero or negative amounts. 

Utilities 

• Utilities > Ad Hoc Reports: Updated the Ad Hoc grid to build dynamically to avoid using 
old column names. 
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July 29, 2021 (Version 12.3.0) 
 

Enhancements 

Donors And Gift 

• Reports > Pledge List: Added a filter option to “Print Only Subdonors?”. 

Insurance Billing 

• Modify > Employee Information: Added a Total line to the Insurance grid under 
Employee Information. 

Payroll 

• Reports > 941 Summary: Added new Form 941 2021 for second quarter. Also added 
several downloadable worksheets that can be used to complete the updated Form 941. 

• Modify > Tax Table Information: Updated New York State's payroll withholding rates. 

• Modify > Tax Table Information: Updated Idaho tax tables. 

Remittance 

• Enter > Remittance: Remittance Entry now provides a new field to enter pledged 
amount, along with the existing field for total check amount. 

• Reports > Statements: Added an option to send Remittance Statements without PDF 
security. 

Fixes 

Accounts Payable 

• Manage > Unposted Transactions > Import Transactions: The import feature now 
accepts negative values. 

• Manage > Payment Processing: The invoice detail lines on the Check Stub and Check 
Register now sort the Description alphabetically. 

• Reports > Contractor Report: The Contractor Report now honors selected date range 

• View > Transaction Inquiry: Fixed word wrapping so long invoice numbers would not 
be truncated. 

• View > Transaction Inquiry: Fixed an error that occurred when reprinting checks 
without a journal ID. 
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Accounts Receivable 

• Manage > Recurring Charges: Corrected an issue with AR items that used only 
numbers for the description so that the unit price and item description would load 
alongside the detail line when adding it to a recurring charge or invoice. 

• Manage > Payment Processing: Fixed an issue where the Payment Processing reports 
was returning a No Results message when processing a payment using a discount. 

• Reports > Discount Report: Fixed an issue where the report was not displaying all 
transactions. 

Bank Account Management 

• Manage > Bank Statement: Corrected an issue when reconciling bank statements and 
using the Parent account and associated Sub-accounts. The program now includes all 
Parent account activity along with its sub-accounts when reconciling to bank statement. 

Deposits On Hand 

• Utilities > Inactivate or Renew an Account: Corrected running report in the 
background when no transactions are available to inactivate or renew. 

Donors And Gifts 

• Reports > Analysis > Summary: Fixed an issue where the report was not showing the 
summary section.  

• Reports > Analysis > Detail Abbreviated: Fixed the report to show the correct 
columns.  

• Reports > Gifts List > Detail and Summary: Removed the duplication of donor's 
address information from the report. 

• Reports > Gifts List Summary: Corrected the title for the Gift List (Summary). It no 
longer says Gift Detail List. 

• Manage > Unposted Gifts: Corrected Cross Check and Shelby Teller file imports to not 
include ACH when assigning routing/account numbers. 

General Ledger 

• Reports > Detail Ledger: Fixed missing account structure in Detail Ledger export file. 

• Modify > Special Reports Setup: Removed Variable Budget from the Special Reports 
(Budgeted Financial Statement). 

• Modify > Year and Periods: Corrected error when deleting the only year in a company 
that has no financial history. 
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Payroll 

• Modify > Employee Information: Corrected an issue with adding or editing MISC 
Hours. 

• Modify > Employee Information: Fixed an error that was appearing when adding 
scheduled time off for Miscellaneous hours when they were set to accrue. 

• Modify > Employee Information: Fixed issue where the program was not enforcing the 
"Minister Only" setting. 

• Manage > Payroll Processing: Corrected the focus of the cursor when tabbing down 
the different fields in the Add New Compensation modal. 

• Manage > Payroll Processing: Fixed an error when trying to add a new compensation 
and the company only has one distribution, and it has already been used in that payroll. 

• Manage > Payroll Processing: Fixed issue when creating distributions for a 
compensation that is set to use regular pay only so that it uses the same regular pay 
account in all hidden accounts, and that when processing payroll, only the option for 
regular pay appears. 

Pension Billing 

• Modify > Charge Information: Added checks to delete a charge so that a charge can be 
deleted when it is not associated with other records or has activity marked as inactive. 

• Modify > Appointment Information: Set the Housing Allowance to round to whole 
dollar amount when using Parsonage. 

• Modify > Appointment Information: Program no longer automatically adds a Charge 
when adding a new appointment. 

Portal 

• Portal > Remittance: Fixed the bottom section of the online payment screen to 
reference the correct company when paying remittances in the portal. 

Purchasing Management 

• Manage > Requests: Fixed issue where the Period drop down could reset to first option 
when changing between pages.  

• Manage > Requests: Fixed the Req # field to accept and keep alpha numeric characters. 

• Manage > Requests: Fixed the Filters bar so that it did not become hidden upon running 
the Print List report. 
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Remittance 

• View > Inquiry: The Inquiry now includes non-pledged values. 

• Manage > Unposted Remittances: Removed the error notification when there is a zero 
pledged amount involved. 

• Manage > Unposted Remittances: Corrected an issue when posting remittance. The 
program now creates a General Ledger journal entry with the correct values, and it posts 
to the correct bank account based on if it is a manual entry or from the online portal. 

Security 

• Security Setup > Task Roles: Corrected tabs security to correct issue with Donors and 
Gifts security roles. 
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June 30, 2021 (Version 12.2.1) 
 

Hot Fix (hosted customers) - Accounts Payable > Manage > Payment Processing: Fixed an 
issue introduced with the 12.2.0 Patch that caused an error when finalizing checks if you were 
operating on a cash basis. 

Enhancements 

Accounts Payable 

• Reports > Vendor List: Added a CSV export option. 

Accounts Receivable 

• View > Transaction Inquiry: Fixed an issue that caused the scroll bar at the bottom of 
the list to disappear. 

General Ledger 

• Modify > Chart of Accounts: Removed two account fields that are currently not being 
used: GAAP Restriction Type and Functional Expense Type. 

Remittance 

• Modify > Activity Information: Added a Parent column to the Activity Information 
screed which will show the Parent Activity for linked Sub-activities. 

Fixes 

Accounts Payable 

• Manage > Payments: Corrected a layout issue on the Check Register display. 

• Manage > Payment Processing: Corrected the Note text layout on the Accounts 
Payable Check stub. A list type view is now supported. 

• View > Transaction Inquiry: Fixed an issue that caused the scroll bar at the bottom of 
the list to disappear. 

Accounts Receivable 

• Reports > Statements: When sending AR statements without PDF Security selected, the 
program now does not send instructions for opening the document. 

Donors And Gifts 

• Reports > Commemoratives List: Removed header information where no matching 
data is found. 



Financials Release Notes 
 

13 
 

• Reports > Statements: Other Tax Amounts now includes the "other tax amounts" 
correctly. 

• View > Posted Gifts: Deleting a gift now sends correct values to Bank Account 
Management. 

General Ledger 

• Reports > Budgeted Financial Statement: Corrected an Error notification when trying 
to run the Budget Information report with Include Opening and Ending Balances for each 
Department Name was selected. 

• Reports > Preliminary Budget Report: Added two columns to the Preliminary Budget 
Excel export:  Variance $ and Variance %. 

• Modify > Company Information: Added phone number option to allow non-U.S. 
numbers to be entered correctly when non-U.S. country is selected. 

Portal 

• Portal: Improved the Portal View for Firefox users. 

• Portal: Changed the portal to display Current Hours Available (Hours Remaining from 
Employee record) when accessing the Payroll Request Time Off section. 

Payroll 

• Manage > Payroll Processing: Corrected an issue where emailed Payroll vouchers were 
not displaying Accrued Time Off Hours. 

• Manage > Payroll Processing: Corrected a calculation issue where the regular pay also 
includes a bonus type distribution. 

Remittance 

• Manage > Unposted Remittances: Corrected an issue where rounding amounts were 
going to the Activity Bank Account causing the General Ledger Journal to be out of 
Balance with the Online Payment. 
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June 17, 2021 (Version 12.1.1) 
 

Fixes 

Accounts Payable 

• Reports > Aged Analysis: Fixed an issue when reporting totals for invoices that had 
multiple detail lines. 

General Ledger 

• Reports > Statement of Financial Position: Corrected a red error that occurred when 
using “Columnar by Fund”. 

Payroll 

• Manage > Payroll Processing: Corrected an issue where some customers were 
experiencing problems when reprinting Payroll vouchers. 

Portal 

• Portal > Accounts Receivable: Fixed the Accounts Receivable tile in the Home Screen 
of the Portal to display information for only those revenue centers set to show in the 
portal. 
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June 11, 2021 (Version 12.1.0) 
 

Enhancements 

Accounts Payable 

• Change > Current Financial Settings: Credit Cards when viewed under Current 
Financials Settings now show in alphabetical order. 

• View > Transaction Inquiry: Added Filter options “Show Detail Lines with Projects” and 
“Show Detail Lines without Projects”.  You can still Select Project(s) and choose to Select 
all or specific projects. 

Accounts Receivable 

• Manage > Unposted Invoices: Added Filter options for ACH transactions. 

Payroll 

• Manage > Payroll Processing: MICR Plus vouchers now includes ACH information. 

Portal 

• Portal: The Portal now has an updated look. 

Remittance 

• View > Inquiry: Changed the Column titles to better describe listed values. 

• Utilities > Import Pledges > Import Excel Interface File: Added an option where 
users can have the application “Round each pledge amount to the nearest dollar amount”. 

Fixes 

Accounts Payable 

• Manage > Credit Card > Statements: Fixed a post back error when switching pages in 
the Credit Card Reconciliation screen when there are enough transactions to create more 
than one grid page. 

• Reports > Aged Analysis: The report now includes Tax, Freight, and Other Charges 
values where they exist. 

• Manage > Unposted Transactions: Corrected an issue where the Person Search modal 
sometimes duplicated items in the Applications list. 
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General Ledger 

• Modify > Chart of Accounts: Fixed the Edit Account screen to allow the users to switch 
back to 'None' for the Functional Expense Type drop down. 

• Enter > Manual Journal: Corrected the manual journal entry where the program was 
not accepting the system calculated value on the second row. 

• View > Posted Journals: Corrected an error notification that occurred when Filtering on 
an Amount that had a dollar sign along with a value. 

Payroll 

• Reports > 941 Summary: Corrected a Form 941 box 7 value issue. 

Portal 

• Portal > Accounts Receivable: Error will no longer happen accessing the “Pay Invoices” 
section in the portal if the user has certain account rights. 

• Portal > Login: The Portal now accept organization type names when logging in. 

Purchasing Management 

• Manage > Requests: The Copy option no longer pulls incorrect dates. 

Remittance 

• View > Inquiry: For Remittance users that use sub-activities, we fixed the Inquiry list to 
show all sub-activities indented and below Parent activities. 

• Reports > Activity Comparison Report: For Remittance users that have added Sub-
Accounts, the Activity Comparison Report now shows sub-activities indented and below 
the associated Parent activities. 

• Reports > Activity List: For Remittance Users that have added Sub-Accounts, the 
Activity List now shows sub-activities indented and below the associated Parent activity 

• Reports > Conference Summary Report:  For Remittance Users that have added Sub-
Accounts, the Conference Summary Report now shows sub-activities indented and below 
the associated Parent 

• Reports > Detail Remittance List: The Sub-activity report no longer duplicates the 
Church Name. 

• Reports > Status Reports: For Remittance Users that have added Sub-Accounts, the 
Status Report now shows sub-activities indented and below the associated Parent activity. 
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May 26, 2021 (Version 12.0.1) 
 

Fixes 

Payroll 

Compensations: A Hot Fix was applied to resolve an issue where manually created 
Compensations were not showing or available in reports. This only affected Hosted customers 
with version 12.0.0.  

(See the 12.0 release notes below.) 
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May 26, 2021 (Version 12.0) 
 

Enhancements 

Accounts Receivable 

• Modify > Statement Design and Invoice Design: Added Bill To Alternated ID and 
Customer Alternate ID options to the Items list under the Heading/Footing tab. 

Remittance 

• Modify > Company Preferences > Online Column Options: New Feature for the 
Remittance Portal. 

You now have the ability to modify the Remittance Portal layout as follows: 

o You can hide any of the existing columns, except for Payments.   

o You can change the name of any of the existing columns, except for Payments. 

o Just open Remittance, Modify, Company Preferences  

o Click the Online Column Options tab 

o To hide a column, just delete the column description 

o To modify a column, just change the description 

o Click the Update button when finished 

• Portal: Updated the Billing Information section in the portal to just one name field, 
versus having a First and Last Name field, so that organizations can process payments 
with their full organization name. This field will expect the name to be entered as shown 
on credit card. 

Fixes 

Accounts Payable 

• Manage > Unposted Transactions > Import Transaction: Fixed a rights issue in AP 
where Admins and users with full rights were blocked from importing transactions. 

• Manage > Unposted Transactions: Corrected the alignment of the Invoice Date, and 
invoice number fields. 
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Accounts Receivable 

• General: Corrected a problem where the Accounts Receivable application was not 
honoring Account Rights settings. 

• Reports > Payment Reports: The report now including unapplied cash in totals. 

• Reports > Aging Period Summary: The report now shows payments and unapplied 
cash values correctly. 

Donors And Gifts 

• Reports > Commemoratives List: Corrected an issue where clicking Next Page made 
all commemoratives disappear. 

Payroll 

• Modify > Compensation: Removed the Direct Payment of Moving Expenses from the 
Compensation list.  IRS changed the rules on treatment of moving expenses. 
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May 6, 2021 (Version 11.3) 
 

Enhancements 

Accounts Receivable 

• Manage > Unposted Invoices: Added an option to Import Transactions from an Excel 
file. 

Bank Account Management 

• Modify > Bank Account Information: Added a new option “Roll up Sub Accounts?”, 
which allows users to have one bank account along with additional sub-accounts.  In 
General Ledger Reports, users can take advantage of the existing options of showing or 
summing up sub-accounts. Bank Account management now allows the same type of 
option, where the Bank Account Reconciliation takes place in the "parent" account. 

Fixes 

Accounts Payable 

• Manage > Unposted Credit Card Transactions: Fixed the Edit Report to display 1099 
codes. 

• Manage > Payment Processing: Corrected the net amount on MICR checks stubs when 
using discounts, Tax, Freight, and Other. 

• Manage > Recurring Payments: The Edit Report no longer excludes existing values for 
Tax, Shipping, and Other charges. 

• Manage > Unposted Transactions: Corrected the AP Total in the GL Input Audit 
report to include amounts from the "Send EFT to Manage Payments" transactions. 

• Manage > Unposted Transactions: Corrected an Accounts Payable Import issue where 
the import file contained duplicate vendors and / or duplicate Invoice Numbers. 

• Manage > Unposted Transactions: The Import Transactions for Invoices was corrected 
to include multiple lines when including an invoice number. 

Accounts Receivable 

• Accounts Receivable: Corrected a problem where the Accounts Receivable application 
was not honoring Account Rights settings. 

• Manage > Recurring Charges: Fixed the Payment Schedule Date filter to work properly. 
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• Manage > Recurring Charges: Corrected the Item Search modal to prevent it from 
displaying items not marked to be included in recurring charges. 

• Reports > Sales Report: Changed to display a message “Criteria Did Not Return Any 
Results” when no valid results were found. 

• Modify > Statement Design: Newly added images to Statement Design and 
Invoice Design formats are now being retained after user deletes an existing design 
format. 

Donors And Gifts 

• Reports > Statements: Corrected the values showing under the "Other Amount" 
column. 

• Modify > Statement Design: Fixed the Donor Name field in the statement design so 
that it no longer displays Person ID and salutation. 

General Ledger 

• Modify > Budget Information: Corrected an issue where the Budget Import tool was 
not allowing an annual distribution correctly. 

Now the import program works as follows: 

* If no values are given for any period, the Annual Budget will be evenly distributed by 
period with any rounding being added to first period.  
* If a value is given for any period, then the distribution type will be "By Period", if no 
prior distribution type exists.  This will not override the prior distribution type if one 
exists. Also, if the distribution type is "By Period", the "Annual Budget" column will be 
ignored.  
* The import will either be “By Period” or “Annual” 

• Modify > Chart of Accounts: General Ledger's Modify Budget Information Report has 
been corrected to show correct Positive / Negative figures in the Current Budget column. 

• Modify > Chart of Accounts: Fixed so that if an account is edited on a page other than 
page 1, it will not take the user back to the first page on the accounts grid upon updating. 

• Reports > Functional Expense Report: In the Functional Expense Setup, Step 4, the 
program was not allowing the use of decimals in Percentages. 

• Manage > Unposted Journals: Fixed so that the Reverse Only, Copy Only, and Reverse 
& Copy no longer return an error when the Note is close to 4,096 characters. 

• Reports > Financial Spreadsheet: Corrected the report columns to display the amounts 
under the correct periods when there is no Audit period. 

• Reports > Statement of Financial Position: Corrected the Statement of Financial 
Position "Suppress Zero Balances" option to work with the option "Columnar By Fund 
Name?". 
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• Reports > Statement of Financial Position: Corrected the Columnar by Fund report so 
that Column Headers are wrapping properly. 

• Reports > Statement of Financial Position: Corrected a layout issue when exporting 
the Columnar by Period report to Excel. 

• Manage > Unposted Journals: The Journal Edit Report “Change Appearance Settings” 
are now working correctly under Options. 

• Manage > Unposted Journals: Fixed account rights to honor specific company. 

Payroll 

• View > Earnings Inquiry: Corrected a layout issue on checks and vouchers, where 
overlapping occurred. 

• View > Earnings Inquiry: Corrected the calculation for Available Time Off when 
reprinting Vouchers or Checks. 

• Manage > Payroll Processing: Fixed the “#of Days Worked” field in the Check 
Information modal to properly calculate the amount of days worked when entering the 
date format as MMDD and then tabbing away. 

• Manage > Payroll Processing: Running the Payroll Edit Report now includes the Time 
and Date along with Page Numbers at the bottom of the report. 

• Reports > Workers Compensation: The report no longer includes blank pages between 
each printed page. 

Remittance 

• Reports > Statements: Corrected an issue where “Receipts To Date” was not including 
all Remittance history. 

• Enter > Remittance: When adding an additional Activity row, the program no longer 
puts it at the top of the grid. 

Utilities 

• Utilities > Combine Duplicates: Corrected an issue where the program was not 
combining church records properly in Remittance. 
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March 31, 2021 (Version 11.2.0) 
 

Enhancements 

Accounts Receivable 

• Reports > Monthly Statements: Added option to send statements via email without 
securing the PDF. 

Payroll 

• Reports > 941 Summary: Added 941 forms for 2021. E-Filing coming soon. 

Fixes 

Accounts Payable 

• Manage > Payment Processing: Fixed MICR check to honor the option to 'Print 
Summarized Invoice on Check Stubs' when selected. 

• Manage > Payment Processing: Fixed the 'First Check #' field in the Check Information 
modal when processing checks to not allow alphanumeric characters. 

• Manage > Payment Processing: Corrected Payment Processing so that it did not 
generate an empty zip file download when processing MICR vouchers and the option to 
'Print Emailed Vouchers' is unselected. 

• Reports > 1099s: Added the ability to filter 1099 vendors by adding two new fields to 
the Misc category so that it is possible to filter by minimum amounts in Box 1 “Rents” 
and/or Box 2 “Royalties". 

• Reports > Aged Analysis: Fixed the Aged Analysis report to include EFTs when using 'by 
Date' or 'by Period'. This applies to the EFTs that go directly to Manage > Payment 
Processing. 

• Enter > Transaction: Name Search model now keeps correct focus. 

Accounts Receivable 

• Manage > Payment Processing: Adding a new ACH account in within the payment 
entry screen no longer produces an error. 

• Manage > Recurring Charges: The program now posts to General Ledger correctly 
even if the charge contains zero quantity. 

• Reports > Monthly Statements: Corrected statements to show the Customer name on 
invoice description only when it is different than the Bill To. 
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• Manage > Unposted Invoices: Fixed Unposted Invoices so that it properly handles the 
editing of an existing invoice after the option to 'Save Invoice Detail as Separate Invoices' 
has been selected. 

Fixed Assets 

• Reports > Selections And Listings: Fixed the Selections And Listings report builder to 
populate the correct report(s) when the Excel export is selected. 

Donors And Gifts 

• View > Posted Gifts: View Posted Gifts screen's sort by column now displays data 
correctly. 

• Widgets: Corrected the Gifts Pledges widget so that it would no longer become 
unavailable if the user switched it for another widget. 

General Ledger 

• Modify > Budget Information: Corrected an issue with the Export Budget Report where one level was 
not summing correctly. 

• Reports > Chart of Accounts: Fixed the Chart of Accounts report to be able to display 
results when filtering by inactive account. 

Payroll 

• Manage > Payroll Processing: Pay stub now correctly shows accrued hours when 
Maximum has occurred. 

• Manage > Payroll Processing: Corrected issue for MICR checks where the last 4 digits 
of the Social Security number printed zeros. 

Purchasing Management 

• Manage > Requests: Corrected the handling of a redirect from the Purchasing 
Management request email notification back to the application if the request has been 
deleted. This will no longer cause an error. 

Remittance 

• Modify > Statement Design: Corrected issue that reported an error when adding an 
image to the Remittance Statement design. 
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March 16, 2021 (Version 11.1.0) 
 

Enhancements 

Accounts Payable 

• Manage > Unposted Transactions: Users can now import invoices into the Accounts 
Payable Application using and Excel file. 

Remittance 

• Enter > Remittance: Remittance now supports sub-activities.  Values entered to a sub-
activity will go towards satisfying the parent activity. 

• Reports > Statements: Remittance Statement now supports showing values applied to 
sub-activities and those values will go towards satisfying the parent activities' pledge 
amounts. 

• Modify > Activity Information: Remittances now provides a location to define Parent 
and associated sub-activities. 

Security 

• Security: When logging into Shelby Financials each user must supply an active email 
address if one does not exist. 

Fixes 

Accounts Payable 

• Manage > Payment Processing: MICR checks no longer strip out punctuation and 
spaces from phone numbers. 

• View > Transactions Inquiry: Removed a User Name where no user is selected. 

• View > Transaction Inquiry: Fixed a security setting which was allowing users access 
to create Credit Card Transactions. 

• Modify > Vendor Information: Fixed Vendor Information so that records that are 
already associated with Accounts Payable (even if marked inactive) no longer appear in 
the Add New Vendor modal. 

• Reports > 1099s: Fixed a 1099 E-File issue which was not allowing long vendor names. 

• Reports > 1099s: Fixed Georgia State's information needed in Box 6 on Form 1099. 
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Donors And Gifts 

• Manage > Unposted Gifts: Fixed an issue that was causing some transactions coming 
from Donors and Gifts to populate the wrong Bank Account Management account. 

General Ledger 

• Manage > Unposted Journals: Fixed an issue where General Ledger was allowing 
entries with zero values in both Debit and Credit rows. 

• Manage > Unposted Journals: Fixed an issue with the General Ledger Excel import file 
that occurred if an imported row contained zeros. 

Loan Processing 

• Utilities > Post Invoices: Fixed the issue affecting the Present Loan Amount where it 
was showing to be the same amount as displayed under Past Due Principal. 

• Modify > Preferences: Corrected an Error message if application is running on a Cash 
Basis. 

Payroll 

• Manage > Payroll Processing: MICR checks no longer strip out punctuation and spaces 
from phone numbers. 

• Manage > Manual Checks: Fixed Manual Check Edit Report and Manual Check Final 
Register to include non-tax deductible compensation amounts in the Final Totals line 
under the Compensation column. 

• Reports > ACA Reporting: The email addresses associated with ACA EFile transactions 
now upload correctly. 

Pension Billing 

• Modify > Appointee Information: Housing Allowance amount can now be zero. 

• Modify > Appointee Information: Pension Billing now allows users to delete new and 
edited appointments. 

Purchasing Management 

• Manage > Requests > Payment Approval: Corrected an issue that caused the 
application to show a check number and check date for unpaid invoices. 

• Portal> Purchasing Management: Fixed the Portal so that Remaining Budget will not 
show when it is deselected in Accounts Payable.  
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Remittance 

• Reports > Detail Remittance List: Fixed the report so that when page breaking by first 
sort, the Alternate ID, Conference #, and Address shows on all records and not just the 
first church. 

• Modify > Activity Information: Fixed the filters to no longer get reset after 
opening/editing an activity. 

• Manage > Pledges: Fixed a refresh issue with the Person Search modal when clicking 
Add New Pledge. 
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February 26, 2021 (Version 11.0.0) 
 

Enhancements 

General 

• Utilities > Ad Hoc Reports: Added a description, or Alias, to the columns showing on 
column headings in the Data Grid view.  This makes it easier to use an exported file as 
well as allows the selection of common named fields from multiple entities.  For example, 
"Name" appears in many entities, but in previous releases the Data Grid only included one 
column even if multiple like named fields were selected.  

Payroll 

• Modify > Tax Tables: Corrected an issue on the Payroll State Tax modal's field "Reduce 
Tax Basis By" so that the state's taxable basis is not reduced by any amounts entered in 
this field. 

Security Setup 

• Users: Added security feature where administrators and regular users will receive email 
notifications when a change is made to their Shelby Financials login. 

Fixes 

Accounts Payable 

• Manage > Payment Processing: Corrected an issue where some items were marked 
"selected" but did not show using some filter settings, were processed.  Program now only 
processes selected and viewable items. 

• Manage > Payment Processing: Fixed the issue where selected ACH items were 
included with selected checks.  The program only was emailing the first listed voucher and 
not allowing a reprint. 

Account Receivable 

• Portal: Made a change where if a revenue center does not have an online title and 
description, it will no longer appear in the portal. 

Bank Account Management 

• Manage > Bank Statements: Corrected an issue that occurred during reconciliation 
when user changed the Statement Period field.  Program now refreshes the screen so 
correct values are displayed. 
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• View > All Items > Add New Item: Corrected issue where a new item was not always 
showing, and therefore not included in the calculations. 

Donors And Gifts 

• Reports > Giving List: When including Purposes for the report, the program now 
produces a page including the totals for selected purposes. 

Payroll 

• Manage > Payroll Processing: Fixed emailed and re-printed vouchers to include 
accrued hours. 

• Reports > ACA Reporting: Added easy way to add additional family members in the 
ACA Report. 
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